Rechercher
 
 

Résultats par :
 


Rechercher Recherche avancée

Derniers sujets
» problème de code
Ven 14 Juil - 14:17 par muratime

» recherche openholdem
Dim 29 Jan - 10:57 par scl2b

» petite question sur certain terme OH
Jeu 19 Jan - 17:49 par toto

» problème de bouton all in
Jeu 19 Jan - 5:33 par toto

» Oh V9
Mar 6 Déc - 13:43 par TKAP

»  OpenPPL V 1.3.1
Ven 11 Nov - 8:17 par matom

» bonjour
Ven 11 Nov - 8:04 par matom

» NO TRIAL HUD supprimer le message "TRIAL please register" du hud dans pokertracker
Dim 12 Juin - 11:36 par BOTTER

» Comment avoir illimité PT3 ou 4 version trial (mode d'emploi)
Ven 10 Juin - 4:11 par muratime

Qui est en ligne ?
Il y a en tout 1 utilisateur en ligne :: 0 Enregistré, 0 Invisible et 1 Invité

Aucun

Le record du nombre d'utilisateurs en ligne est de 28 le Lun 26 Nov - 13:32
Statistiques
Nous avons 152 membres enregistrés
L'utilisateur enregistré le plus récent est Kyar

Nos membres ont posté un total de 2280 messages dans 310 sujets

Petit problème de configuration ?

Voir le sujet précédent Voir le sujet suivant Aller en bas

Petit problème de configuration ?

Message par Titi007 le Mer 26 Déc - 8:26

Je dois avoir un petit problème quelque part. Vous vous rappelez qu'après ma 1ère tm (PA) lorsque j'ai connecté OH il est parti à tapis avec 84o. Et bien là 1er script pour débuter mon apprentissage: il part de nouveau à tapis alors que ce n'est pas prévu. Je teste en mode manuel.
Le script ne comporte que quelques lignes très simples, par exemple:
WHEN (Hand = AA) RAISE 4 FORCE
WHEN Others FOLD FORCE
Je n'ai que les sections PREFLOP, FLOP, TURN et RIVER...
Je convertis ce .txt en .ohf et je teste avec AA... j'active les boutons FCRA... il étudie et élimine un par un les boutons R (pas normal), C et F et il envoie tapis ?!

Avez-vous déjà rencontré ça ? (on pourrait mettre en cause la tm, mais j'utilise la tm du mode manuel, je ne l'ai pas touchée, donc je n'ai pas pu y faire de bêtises)



Titi007
Membre

Messages : 236
Date d'inscription : 15/12/2012
Localisation : France

Revenir en haut Aller en bas

Re: Petit problème de configuration ?

Message par BOTTER le Mer 26 Déc - 8:34

Titi007 a écrit:Je dois avoir un petit problème quelque part. Vous vous rappelez qu'après ma 1ère tm (PA) lorsque j'ai connecté OH il est parti à tapis avec 84o. Et bien là 1er script pour débuter mon apprentissage: il part de nouveau à tapis alors que ce n'est pas prévu. Je teste en mode manuel.
Le script ne comporte que quelques lignes très simples, par exemple:
WHEN (Hand = AA) RAISE 4 FORCE
WHEN Others FOLD FORCE
Je n'ai que les sections PREFLOP, FLOP, TURN et RIVER...
Je convertis ce .txt en .ohf et je teste avec AA... j'active les boutons FCRA... il étudie et élimine un par un les boutons R (pas normal), C et F et il envoie tapis ?!

Avez-vous déjà rencontré ça ? (on pourrait mettre en cause la tm, mais j'utilise la tm du mode manuel, je ne l'ai pas touchée, donc je n'ai pas pu y faire de bêtises)



Envoie ton code ici que je regarde.
avatar
BOTTER
Admin

Messages : 754
Date d'inscription : 07/04/2012
Localisation : Canada

http://openholdem.forumcanada.org

Revenir en haut Aller en bas

Re: Petit problème de configuration ?

Message par fold95 le Mer 26 Déc - 9:26

Titi007 a écrit:j'active les boutons FCRA... il étudie et élimine un par un les boutons R (pas normal), C et F et il envoie tapis ?!
En manuelle mode c'est normal la première action qu'il fait est la bonne, comme il ne voie pas de réaction il continue à cliquer.


fold95
Membre

Messages : 313
Date d'inscription : 13/04/2012

Revenir en haut Aller en bas

Re: Petit problème de configuration ?

Message par Titi007 le Mer 26 Déc - 12:02

D'accord je crois avoir compris: dans la barre d'état OH l'action proposée est correcte (betsize). Comme l'autoplayer ne voit pas d'effet sur le ManuelMode, tu me dis fold qu'il clique partout...
Donc en fait je dois reproduire manuellement l'action qu'il propose tout en bas à droite dans la barre d'état ?

Tant que j'y suis je pose une autre question (qui n'est pas à sa place ici). J'ai donc continué à programmer histoire de découvrir le langage. Mais je me dis que pour aboutir à un bot complet, le code fera donc quelques milliers de lignes et je suppose qu'il faut partir d'une base "saine" que l'on modifie pour l'adapter au style de jeu désiré. Quelle base préconisez-vous ? Par base je suppose un code "minimal" que l'on enrichit ensuite. Parce que les codes déjà tout fait, ce n'est peut-être pas l'idéal pour commencer: se plonger dans plusieurs milliers de lignes suppose déjà une bonne expérience du langage, de plus modifier ce code peut vite devenir un danger si on met maladroitement des modifications à droite, un peu à gauche, bref le plat de spaghettis vite ingérable ?!

Titi007
Membre

Messages : 236
Date d'inscription : 15/12/2012
Localisation : France

Revenir en haut Aller en bas

Re: Petit problème de configuration ?

Message par fold95 le Mer 26 Déc - 13:04

Titi007 a écrit:D'accord je crois avoir compris: dans la barre d'état OH l'action proposée est correcte (betsize). Comme l'autoplayer ne voit pas d'effet sur le ManuelMode, tu me dis fold qu'il clique partout...
Donc en fait je dois reproduire manuellement l'action qu'il propose tout en bas à droite dans la barre d'état ?

il ne clique pas forcément partout, mais oh à un code jeux a sa racine par exemple tu as AA ton code lui demande de bet 4 BB s'il ne voit pas de réaction il va essayer de call ou d'allin pour ne pas perdre la main.
Oui tu dois reproduire le bet manuellement si tu veux suivre le reste du coup.

Titi007 a écrit:Tant que j'y suis je pose une autre question (qui n'est pas à sa place ici). J'ai donc continué à programmer histoire de découvrir le langage. Mais je me dis que pour aboutir à un bot complet, le code fera donc quelques milliers de lignes et je suppose qu'il faut partir d'une base "saine" que l'on modifie pour l'adapter au style de jeu désiré. Quelle base préconisez-vous ? Par base je suppose un code "minimal" que l'on enrichit ensuite. Parce que les codes déjà tout fait, ce n'est peut-être pas l'idéal pour commencer: se plonger dans plusieurs milliers de lignes suppose déjà une bonne expérience du langage, de plus modifier ce code peut vite devenir un danger si on met maladroitement des modifications à droite, un peu à gauche, bref le plat de spaghettis vite ingérable ?!

En fait il est très difficile de créer un code entier dès que l'on commence à apprendre le langage, il est preferable de t'inspirer d'un script existant et de le modifier.
Ce n'est pas grave si ton code présente des milliers de lignes si tu comprends le Ppl, si tu veux un conseil travaille le preflop dans un premier temps et utilise un postflop déjà codé car ce dernier est ce qui a de plus dure à réaliser, tu veux jouer quoi?

fold95
Membre

Messages : 313
Date d'inscription : 13/04/2012

Revenir en haut Aller en bas

Re: Petit problème de configuration ?

Message par BOTTER le Mer 26 Déc - 13:37

Pour le manuel mode fold a fait un bon petit tuto ici : [Vous devez être inscrit et connecté pour voir ce lien]

Titi007 a écrit:Tant que j'y suis je pose une autre question (qui n'est pas à sa place ici). J'ai donc continué à programmer histoire de découvrir le langage. Mais je me dis que pour aboutir à un bot complet, le code fera donc quelques milliers de lignes et je suppose qu'il faut partir d'une base "saine" que l'on modifie pour l'adapter au style de jeu désiré. Quelle base préconisez-vous ? Par base je suppose un code "minimal" que l'on enrichit ensuite. Parce que les codes déjà tout fait, ce n'est peut-être pas l'idéal pour commencer: se plonger dans plusieurs milliers de lignes suppose déjà une bonne expérience du langage, de plus modifier ce code peut vite devenir un danger si on met maladroitement des modifications à droite, un peu à gauche, bref le plat de spaghettis vite ingérable ?!

Moi de mon coté je suis partie a 0 ligne et je suis rendu a 1720 ligne de code. J ai essayer d adapter un code pour moi mais des fois les codes sont vraiment le bordel donc pas facile de ce retrouver. Donc j ai decider de partir de 0. Je joue sur poker academie et corrige au fur a mesure ce que je n aime pas, Je le connais bien c est le miens. Ton bot doit etre capable de battre les bots de poker academie ou poker th en premier. Quand tu réussie a les batre sur 2000 a 3000 mains bien tu peu le tester en reel et le readapter a nouveau, car en reel c est different. J ai placer le graph de mon bot quand il a jouer sur poker academie. c est le tracker de poker academie. Par contre je ne joue pas encore beaucoup avec en reel. bientot.... voici le graph de mon bot, c est graph on un certain temps et depuit le bot a ete modifier. j en posterais d autre bientot.

[Vous devez être inscrit et connecté pour voir cette image]
avatar
BOTTER
Admin

Messages : 754
Date d'inscription : 07/04/2012
Localisation : Canada

http://openholdem.forumcanada.org

Revenir en haut Aller en bas

Re: Petit problème de configuration ?

Message par Titi007 le Mer 26 Déc - 16:37

Merci bien pour vos réponses.
Dans un premier temps je vais m'orienter vers la variante que je connais le mieux et où je suis gagnant (CG Full Ring), ainsi j'ai des bases sûres: si j'arrive à le faire jouer comme moi, en le connectant à ma base poker tracker...
Le SH ça me semble difficile à programmer tellement les informations sur les joueurs sont importantes, et pas seulement les données du tracker.
En MTT, là il me faudrait carrément des cours Very Happy Je ne me suis pas vraiment lancé dessus.

Dans les profiles que vous mettez en partage, j'ai testé le Zulu. Pour le modifier, avez-vu le code OpenPPL qui est plus lisible que le fichier .ohf ? Ou bien y-a-t-il un outil dans OpenPPL pour remonter au code PPL à partir du fichier .ohf ?

Titi007
Membre

Messages : 236
Date d'inscription : 15/12/2012
Localisation : France

Revenir en haut Aller en bas

Re: Petit problème de configuration ?

Message par BOTTER le Mer 26 Déc - 16:50

Titi007 a écrit:Dans les profiles que vous mettez en partage, j'ai testé le Zulu. Pour le modifier, avez-vu le code OpenPPL qui est plus lisible que le fichier .ohf ? Ou bien y-a-t-il un outil dans OpenPPL pour remonter au code PPL à partir du fichier .ohf ?


Je dois avoir la version texte ici. je peu t envoyer ce soir sur ton email d enregistrement si tu desire.
avatar
BOTTER
Admin

Messages : 754
Date d'inscription : 07/04/2012
Localisation : Canada

http://openholdem.forumcanada.org

Revenir en haut Aller en bas

Re: Petit problème de configuration ?

Message par Titi007 le Jeu 27 Déc - 11:43

Oui je veux bien, merci Botter Wink
Ce matin j'ai codé un preflop basique (très serré). Avec ce 1er code, je vois bien sûr l'importance des symbols pour modulariser et éclaicir le code des actions. Comme je ne vois pas de topic de type librairies de symbols, est-ce que ça vous intéresse que je partage ce que je ferai ou bien avez-vous déjà les vôtres et ce n'est pas très intéressant de partager ce genre de choses ?

Titi007
Membre

Messages : 236
Date d'inscription : 15/12/2012
Localisation : France

Revenir en haut Aller en bas

Re: Petit problème de configuration ?

Message par BOTTER le Jeu 27 Déc - 12:17

Titi007 a écrit:Oui je veux bien, merci Botter Wink
Ce matin j'ai codé un preflop basique (très serré). Avec ce 1er code, je vois bien sûr l'importance des symbols pour modulariser et éclaicir le code des actions. Comme je ne vois pas de topic de type librairies de symbols, est-ce que ça vous intéresse que je partage ce que je ferai ou bien avez-vous déjà les vôtres et ce n'est pas très intéressant de partager ce genre de choses ?

C est certain que je voulais traduire tout les symbol du ppl en francais. Par contre je travaille sur mon bot pour metre ca en fonction un jour Very Happy , apres je le ferait, mais par contre si tu desire faire la traduction des symbols ppl va y fort, ecris ca sur le sur un fichier .txt et quand je la ferais je prendrais ceux que tu ma donner et je ferais un post pour ca bien sur en mentionnant ton aide. Car meme moi je me suis perdu un peu de fois avec certain code qui porte a confusion.
avatar
BOTTER
Admin

Messages : 754
Date d'inscription : 07/04/2012
Localisation : Canada

http://openholdem.forumcanada.org

Revenir en haut Aller en bas

Re: Petit problème de configuration ?

Message par Titi007 le Ven 28 Déc - 2:40

D'accord pour les symbols du PPL.
Mais en fait je parlais de symbols nouveaux, ceux que l'on peut créer. Exemple, j'avais besoin de connaître le stack du joueur ayant relancé en dernier: sauf erreur de ma part je n'ai pas trouver de symbol LastRaiserStackSize, donc je l'ai écris. C'est un symbol qui peut être utile à la communauté et si ça peut être utile à d'autres je veux bien le partager. Mais je n'ai pas vu de topic "Partage" dans "OpenPPL", enfin bref je ne sais pas où déposer ce genre de code...
As-tu retrouvé le .txt de Zulu ?

Titi007
Membre

Messages : 236
Date d'inscription : 15/12/2012
Localisation : France

Revenir en haut Aller en bas

Re: Petit problème de configuration ?

Message par BOTTER le Ven 28 Déc - 5:48

Pour ce qui est des nouveaux symbol c est une bonne idee,je vais partir un post it juste pour les nouveaux symbol.

Ca serait cool quand tu auras le temp que tu ouvre un post dans la section Tutorial => Truc ( un petit tuto ) pour apprendre comment ecrire de nouveau symbol, je n est aucune idee comment faire.

La question est, si on inserre de nouveau symbol, pour le PPL c est correct, mais quand on va convertir avec OpenPPL ca va tu passer Question


Dernière édition par BOTTER le Ven 28 Déc - 10:56, édité 1 fois
avatar
BOTTER
Admin

Messages : 754
Date d'inscription : 07/04/2012
Localisation : Canada

http://openholdem.forumcanada.org

Revenir en haut Aller en bas

Re: Petit problème de configuration ?

Message par fold95 le Ven 28 Déc - 9:24

Titi007 a écrit:D'accord pour les symbols du PPL.
Mais en fait je parlais de symbols nouveaux, ceux que l'on peut créer. Exemple, j'avais besoin de connaître le stack du joueur ayant relancé en dernier: sauf erreur de ma part je n'ai pas trouver de symbol LastRaiserStackSize, donc je l'ai écris. C'est un symbol qui peut être utile à la communauté et si ça peut être utile à d'autres je veux bien le partager. Mais je n'ai pas vu de topic "Partage" dans "OpenPPL", enfin bref je ne sais pas où déposer ce genre de code...
As-tu retrouvé le .txt de Zulu ?

C'est une très bonne idée Wink tu peux créer un post-it dans ce même forum étant donné que ce n'est pas un code complet il sera bien placer dans programmation.

fold95
Membre

Messages : 313
Date d'inscription : 13/04/2012

Revenir en haut Aller en bas

Re: Petit problème de configuration ?

Message par fold95 le Ven 28 Déc - 12:13

C'est du bon boulot nice symbol Wink tu as vraiment bien compris le fonctionnement, crée nous un post avec les symbols que tu veux partager ça va grandement aider les membres de la communauté.

fold95
Membre

Messages : 313
Date d'inscription : 13/04/2012

Revenir en haut Aller en bas

Re: Petit problème de configuration ?

Message par Contenu sponsorisé


Contenu sponsorisé


Revenir en haut Aller en bas

Voir le sujet précédent Voir le sujet suivant Revenir en haut

- Sujets similaires

 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum